System Overload
Incident Report for Sitejet
Postmortem

Through an attack against our e-mail infrastructure we experienced a chain reaction that ultimately also resulted in the Sitejet application becoming partially unusable. For example, changes could not be saved or the app did not open at all at times. Also e-mails were delivered with a delay. We apologize very much for the inconvenience caused and take the situation very seriously. After a thorough investigation, we will take several measures in the next few days to prevent such a problem in the future:

  • Better protection against attacks on our email infrastructure
  • Smart balancing of (internal) traffic to prevent chain reactions
  • Improve email processing performance
Posted Feb 22, 2023 - 19:08 CET

Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 18:56 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2023 - 15:19 CET
Update
We are continuing to investigate this issue.
Posted Feb 22, 2023 - 14:29 CET
Update
We are continuing to investigate this issue.
Posted Feb 22, 2023 - 14:14 CET
Investigating
We are currently investigating this issue.
Posted Feb 22, 2023 - 14:00 CET
This incident affected: Project Management, Website Editor, Customer Portal, and API.